ideviceid

flutterの環境構築をしている最中、

$ flutter doctor

を初めて行ったタイミングでエラーが出ました。

“idevice_id”は、開発元を検証できないため開けません。

解消するためには以下コマンドを実行します。

$ sudo xattr -d com.apple.quarantine /Users/yoshikiito/workspace/flutter/bin/cache/artifacts/libimobiledevice/idevice_id

なお、上記の例は私の環境でのサンプルになります。

idevice_idまでのパスは、flutterのインストール時にzipを解凍してどこに置いたかによって変わってきますので、ご自身の環境のidevice_idへのパスに置き換えて実行してください。

参考

【Flutter】“idevice_id”は、開発元を検証できないため開けません。への対処法